Tabplugin: Cambia las pestañas abiertas con Gedit usando el teclado

Gedit es un editor que permite extender sus capacidades usando plugins. Para ver los plugins disponibles, sólo hay que ir al menú Editar/Preferencias y ver la lista de complementos (plugins):

Captura de pantalla de 2013-02-26 11:18:37

Instalando el paquete gedit-plugins se puede aumentar el número de plugins. Y los hay muy útiles como el completado de palabras o la corrección ortográfica. Con los plugins adecuados se llega a convertir un simple editor de texto en todo un IDE de desarrollo con gestión de proyectos, división de documentos (split view), consolas para ejecutar comandos,…

Se pueden descargar más plugins desde:

https://live.gnome.org/Gedit/Plugins

Para instalar un plugin, sólo hay que copiar sus ficheros con extensión “.plugin” y “.py” a la carpeta “~/.local/share/gedit/plugins”. Tan fácil como ejecutar los comandos:

mkdir -p ~/.local/share/gedit/plugins

cp *.plugin *.py ~/.local/share/gedit/plugins

Crear un nuevo plugin es muy simple. De hecho, he escrito mi propio plugin para cambiar la pestaña abierta usando el teclado, teclas ctrl+espacio. El plugin ordena los documentos en función del último documento abierto, por lo que es muy rápido cambiar entre los documentos más frecuentes. Si os interesa lo podéis descargar desde:

https://docs.google.com/folder/d/0B1x9hVRJS4GmVjNFRFpwcVVXYzA/edit?usp=sharing

Anuncios
Esta entrada fue publicada en Software. Guarda el enlace permanente.

7 respuestas a Tabplugin: Cambia las pestañas abiertas con Gedit usando el teclado

  1. Héctor dijo:

    Me he bajado los Splitview y macropy y al abrir gedit:
    (gedit:3312): libpeas-WARNING **: Bad plugin file: ‘/home/user/.local/share/gedit/plugins/SplitView.plugin’

    (gedit:3312): libpeas-WARNING **: Error loading ‘/home/user/.local/share/gedit/plugins/SplitView.plugin’

    No doy con la solución a este problema. Cualquier ayuda se agradecerá.

    • selairi dijo:

      Hola, me he bajado Spliview desde esta página, sólo funciona para Gedit 3 (GNOME 3):

      https://github.com/jonocodes/GeditSplitView

      Después he copiado los ficheros a:

      ~/.local/share/gedit/plugins/

      He inicado Gedit y después he activado la opción de Splitview. He apagado Gedit, y me funciona correctamente.

      Un saludo

      • Héctor dijo:

        Hola selairi, gracias por tu respuesta.

        Sigue sin funcionarme. Estoy bajo:
        Ubuntu
        Versión 12.04 (precise) de 64-bit
        Núcleo Linux 3.2.0-39-generic
        GNOME 3.4.2

        He seguido tus instrucciones y obtengo lo siguiente al ejecutar gedit (también estoy tratando de instalar el plugin de macro:

        (gedit:9955): libpeas-WARNING **: Bad plugin file: ‘~/.local/share/gedit/plugins/SplitView.plugin’

        (gedit:9955): libpeas-WARNING **: Error loading ‘~/.local/share/gedit/plugins/SplitView.plugin’

        (gedit:9955): libpeas-WARNING **: Bad plugin file: ‘~/.local/share/gedit/plugins/macropy.plugin’

        (gedit:9955): libpeas-WARNING **: Error loading ‘~/.local/share/gedit/plugins/macropy.plugin’

        Y en Preferencias no aparecen los plugins que intento instalar.

        Gracias por cualquier comentario.

        Héctor.

  2. Héctor dijo:

    Hola,

    gracias por las respuestas. Finalmente el error era mío: estaba descargando el los ficheros con botón derecho y bajar enlace y, en realidad, no me bajaba el fichero, sino un enlace en html. En resumen, una torpeza por mi parte. Siento los quebraderos de cabeza.

    Héctor.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s